ВремяМетр - отслеживаем события и законы времени

ВремяМетр

Название программы описательное: ВремяМетр - программа по измерению времени, инструмент для изучения его законов.
Цель проекта: постижение феномена времени. Поэтому в рамках проекта будет реализовываться всё, что будет способствовать пониманию этого феномена.
Уже реализованно:
+ Отслеживание событий. Показываются дни рождения, праздники и др. Параметры оповещения настраиваются. Дополнительно показывается когда событию исполнилось особое количество дней, например 1000 или 444
+ Калачакра - тибетский календарь. Характеристики века, года, месяца, недели, дня. Работа со списком событий: сопоставление, графики распределения... подробней здесь
+ Калькулятор дат. Cкладывание и вычитание дат, прибавление/вычитание к дате любое количество дней
+ Периоды (вычисляется длительность периода между датами в годах, месяцах, неделях или днях). Показывается список событий на указанный период.
+ Динамические таблицы. Можно, задавая параметры, строить таблицы для Калачакры, Зодиака и календарь на год.

Кроме этого реализованно:
+ Встроенный редактор событий. Позволяет работать с файлами событий и высказываний
+ Встроенный текстовый редактор. Пока что очень простой, но с поддержкой формата rtf.
+ Настройка внешнего вида программы.
+ Фраза дня.

Задумок уже намного больше, чем времени на их реализацию, поэтому я с радостью готов сотрудничать с программистами заинтересованными в этой теме. Не программисты также могут помочь проекту. Нужны:
- Ссылки на ресурсы посвещённые изучению времени
 - Отзывы о программе, а также замечания и предложения
- Файлы событий и высказываний для подключения к программе
- Дизайн сайта и справки
- Любая другая помощь

Особо приветствуются люди, изучающие календари и могущие изложить их алгоритмы. Я с удовольствием добавлю любые календари в программу.

vmetr.narod.ru
в начало
© Павел Малахов


Работа с событиями

Все операции с событиями можно выполнять либо в Редакторе событий, либо в любом текстовом редакторе, так как файлы храняться в формате простого текста. Во втором случае полезно будет ознакомиться с форматами файлов.

Некоторые операции можно выполнить прямо из главного окна программы, щёлкнув по событию правой клавишей мыши и вызвав контекстное меню:
Редактировать - открывает редактор событий и загружает в него файл где прописано выделенное событие.
Добавить в список - добавить новое событие в Список событий
Отключить - отключить событие, не удаляя из файла, то есть о нём напоминаться больше не будет, но позже его можно будет снова включить
Удалить - удалить событие из файла
Редактор событий - открыть Редактор событий
Настройки - открыть окно с настройками программы, где можно подключить файлы с событиями


Использование программы

Программа обладает интуитивно понятным интерфейсом, поэтому её использование не должно вызвать затруднений. Однако, на всякий случай, здесь описаны основные моменты её работы.

Установка и удаление программы

Добавление событий, их редактирование и удаление

Работа с Калачакрой


Форматы файлов

В программе ВремяМетр есть несколько типов обрабатываемых файлов, которые храняться в формате простого текста, благодаря чему их можно редактировать в любом текстовом редакторе.

I. Конфигурационный файл.
Такой файл один и он всегда имеет имя VremyaMetr.cfg. Он состоит из трёх частей:

1. перечисление подключенных файлов событий
2. перечисление подключенных файлов высказываний
3. опции программы

Общий вид файла:

[Events in]
Файл_с_событиями1.evt
Файл_с_событиями2.evt
...
[end list]

[Wisdom in]
Файл_с_высказываниями1.wis
Файл_с_высказываниями2.wis
...
[end list]

Опция1 = Значение
Опция2 = Значение
...

Программу можно запустить и без конфигурационного файла. Его можно создать, изменив параметры по умолчанию в окне "Настройки".

II. Файлы событий
Первой строкой в файле определяется формат, все последующие - это записи - события записанные по одному в строку в указанном формате. На данный момент поддерживается 3 формата:

1) Фиксированные события. Исторически первый формат. Сейчас уже устарел, т.к. добавлен формат с учётом времени.

[fixed events]
4 10 1957 7 0 1 Запуск первого искусственного спутника Земли

Поля разделены пробелами:
1. День
2. Месяц
3. Год
4. За сколько дней до начала события начать предупреждать
5. Сколько дней после событий продолжать о нём напоминать
6. Нужно ли сообщать о событии. 1 = Да, 0=Нет
7. Событие. Количество символов не должно превышать 1000

2) Фиксированные события с полным указанием срока, т.е. учитывая время. Лучше всего использовать этот формат.

[fixed events with full date]
2007.09.25_16:09:07 1 0 1 Время написания этой строки
1979.07.02_12:00 10 2 1 День рождения любимого человека
1957.10.04 7 0 1 Запуск первого искусственного спутника Земли

Поля разделены пробелами:
1. Срок события в формате Год.Месяц.День_Час:Минута:Секунда
2. За сколько дней до начала события начать предупреждать
3. Сколько дней после событий продолжать о нём напоминать
4. Нужно ли сообщать о событии. 1 = Да, 0=Нет
5. Событие. Количество символов не должно превышать 1000

3) События с переменной датой. Этот формат ещё до конца не утвердился, так как у меня нет достаточного количества событий, чтобы определиться с форматом их хранения.

[float events]
0 5 5 7 0 7 3 1 День сисадмина

Поля разделены пробелами:
1. Астрономическое событие. Это поле зарезервированно на будущее. Справочник этих событий ведётся в .\Template\t_astro_rus.txt
2. День недели
3. Нелеля месяца
4. Месяц
5. Год
6. За сколько дней до начала события начать предупреждать
7. Сколько дней после событий продолжать о нём напоминать
8. Нужно ли сообщать о событии. 1 = Да, 0=Нет
9. Событие. Количество символов не должно превышать 1000

III. Файлы высказываний
Здесь также первой строкой в файле определяется формат, а далее зависит от формата, коих 2:

1) Высказывания разных авторов. После строки формата, следуют записи из двух строк: первая - это высказывание, вторая - автор (допускается пустая строка)

[wisdom]
Никто так не легковерен, как человек неверующий.
Ириней Лионский
Слава богу, я все еще атеист.
Луис Буньюэль

2) Высказывания одного автора. После строки формата следует строка автора всех высказываний в этом файлы, потом высказывания по одному в строку. Если собраны высказывания неизвестных авторов, то строку автора можно оставить пустую.

[wisdom by]
- Жемчужины Востока -
Душа созревает в слезах.
Тысячей сожалений не оплатить и одного долга.
Суди дерево по плодам, а человека по делам.


About

Created using
htm2chm 3.0

Download it NOW!


Вступление

Вся установка сводиться к распаковке архива в желаемый каталог.

Программа не привязывается к каталогу и не использует реестр. Пользователь по желанию может использовать опцию запуска программы при загрузке компьютера, поставив галочку на соответствующему пункте в меню "Сервис" - "Настройки" - "Разное". В этом случае в реестр будет добавлена запись, которая удаляется снятием галочки.

Удаление программы сводиться к удалению каталога, в который она была установлена.


Вступление

Что такое время? Как оно проявляется? Чем измеряется? Слидует ли оно каким-нибудь законам?

Люди меряют время секундами, минутами, годами... Это удобно для взаимопонимания. Однако само время измеряется событиями, ибо время - это характеристика изменяемости, то есть перехода из одного состояния в другое и восприятие человеком изменяемости и есть восприятие времени. Поэтому в одном случае минута может пролететь незаметно, а в другом длиться вечность.

Для понимания природы времени интересно рассмотреть следующие феномены:
1) существование вне времени, то есть когда течение времени не оказывает влияния на наше сознание.


ВремяМетр. Ссылки

Ссылки

Сайты посвящённые изучению времени:

www.chronos.msu.ru - Международное Общество по Изучению Времени

resht.ru - Русская Эзотерическая Школа Теософии им. Е.П.Блаватской. Алгоритмы для вычисления характеристик Калачакры, были составлены по материалам этой школы.

Для любителей праздника каждый день будут интересны сайты:

www.calend.ru - большой список национальных и других праздников


ВремяМетр

{О программе}
{Работа}
{Ссылки}
v.1.0


Работа с Калачакрой

Калачакра - это тибетский календарь. Подробней можно узнать на сайте РЭШТ. Включить или выключить характеристики дня по Калачакре можно в меню Сервис - Настройки - Разное - "Показывать астрологические характеристики дня"

Кроме характеристик дня можно посмотреть и распечатать таблицы, открыв их с помощью меню Калачакра - Таблицы или нажав кнопку "Таблицы" на панели инструментов

Также можно работать со списком событий, добавляя их из контекстного меню главного окна, либо в самом окне Списка событий. Можно открыть любой файл событий и выбрать из него. Единственное условие - у события должы быть указаны год, месяц и день, поэтому события, год которых не известен (а потому в файле указан год = 0) будут показывать неверные характеристики. Можно загрузить файл данных сведений ПФР и узнать распределение по Калачакре своих сотрудников.

События в списке можно сравнивать по характеристикам и их связям. Список можно выгрузить в Excel, где сопоставление более наглядно:

Увидеть распределения событий по кругу Калачакры, особенно наглядно, когда событий много:

и по кругу Зодиака.